Identification

Identifiant
Mot de passe
Mot de passe oublié ?

Partage de documents

Cours



Sondage

Quelle est votre profession ?
Etudiant / Elève
Enseignant / Pédagogue
Webmestre / Développeur
Journaliste / Blogueur
Autre
 
Comment trouvez-vous le système Manhali ?
Très utile
Utile
Peu utile
Inutile

  
 

Chapitre précédent
Chapitre suivant
Correction des exercices 2
Informations sur le chapitre :
Cours : Algorithmique
 
elhaddioui_ismail
  • Auteur : elhaddioui_ismail
  • Créé le : 20/04/2014 - 23:07
  • E-mail : ismail.elhaddioui
  • Modifié le : 27/04/2014 - 15:37
  • Lu : 12581 fois
  • Licence : BY(Paternité) - NC(Pas d'Utilisation Commerciale) - ND(Pas de Modification)
  • Note : 1/62/63/64/65/66/6 (4 Votes : 5/6)
  •  
    • Exercice N° 5

    • Ecrire un algorithme qui permet de calculer le résultat de la division de deux entiers A et B.

      Algorithme Division

      Variables A, B, C : Entiers ;

      DEBUT

      Ecrire ('Donner A et B') ;

      Lire (A, B) ;

      Si (B <> 0) Alors

                  C ← A / B ;

                  Ecrire ('Le résultat de la division est : ', C) ;

      FinSi ;

      FIN

    • Exercice N° 6

    • Ecrire un algorithme qui lit deux entiers A et B, et affiche le plus grand.

      Algorithme Plus_grand_nombre

      Variables A, B : Entiers ;

      DEBUT

      Ecrire ('Donner A et B ') ;

      Lire (A, B) ;

      Si (A > B) Alors

            Ecrire ('Le plus grand nombre est : ', A) ;

      Sinon

            Ecrire ('Le plus grand nombre est : ', B) ;

      FinSi ;

      FIN

    • Exercice N° 7

    • Ecrire un algorithme qui lit trois entiers A, B et C, et affiche le plus grand.

      Algorithme Plus_grand_nombre

      Variables A, B, C : Entiers ;

      DEBUT

      Ecrire ('Donner A, B et C ') ;

      Lire (A, B, C) ;

      Si (A > B) Alors

      Si (A > C) Alors

      Ecrire ('Le plus grand nombre est : ', A) ;

      Sinon

      Ecrire ('Le plus grand nombre est : ', C) ;

      FinSi ;

      Sinon

      Si (B > C) Alors

      Ecrire ('Le plus grand nombre est : ', B) ;

      Sinon

      Ecrire ('Le plus grand nombre est : ', C) ;

      FinSi ;

      FinSi ;

      FIN

    • Exercice N° 8

    • Ecrire un algorithme qui donne l’état de l’eau selon sa température :

      - Si T < 0 : état solide.

      - Si T > 100 : état gazeux.

      - Si 0 < T < 100 : état liquide.

      Algorithme Etat de l'eau

      Variable T : Entier ;

      DEBUT

      Ecrire ('Entrez la température de l'eau : ') ;

      Lire (T) ;

      Si (T < 0) Alors

              Ecrire ('L'état de l'eau est solide') ;

      Sinon

              Si (T > 100) Alors

                        Ecrire ('L'état de l'eau est gazeux') ;

              Sinon

                        Ecrire ('L'état de l'eau est liquide') ;

              FinSi ;

      FinSi ;

      FIN

    • Exercice N° 9

    • Ecrire un algorithme qui donne la mention selon la moyenne générale obtenue par un élève :

      - Si moyenne < 10 : Insuffisant

      - Si 10 < moyenne < 12 : Passable

      - Si 12 < moyenne < 14 : Assez bien

      - Si 14 < moyenne < 16 : Bien

      - Si moyenne > 16 : Très bien

      Algorithme Mention

      Variable Moy : Réel ;

      DEBUT

      Ecrire ('Entrez la moyenne générale : ') ;

      Lire (Moy) ;

      Si (Moy < 10) Alors

      Ecrire ('Insuffisant') ;

      Sinon

      Si (Moy < 12) Alors

      Ecrire ('Passable') ;

      Sinon    

      Si (Moy < 14) Alors

      Ecrire ('Assez bien') ;

      Sinon

      Si (Moy < 16) Alors

      Ecrire ('Bien') ;

      Sinon         

               Ecrire ('Très bien') ;

      FinSi ;

      FinSi ;

      FinSi ;

      FinSi ;

      FIN

    • Exercice N° 10

    • Ecrire un algorithme qui affiche selon un numéro compris entre 1 et 12 le mois équivalent

      Algorithme Mois

      Variable mois : Entier ;

      DEBUT

      Ecrire ('Entrez le numéro du mois : ') ;

      Lire (mois) ;

      Selon que mois vaut

      1 : Ecrire ("C'est Janvier") ;

      2 : Ecrire ("C'est Février") ;

      3 : Ecrire ("C'est Mars") ;

      4 : Ecrire ("C'est Avril") ;

      5 : Ecrire ("C'est Mai") ;

      6 : Ecrire ("C'est Juin") ;

      7 : Ecrire ("C'est Juillet") ;

      8 : Ecrire ("C'est Août") ;

      9 : Ecrire ("C'est Septembre") ;

      10 : Ecrire ("C'est Octobre") ;

      11 : Ecrire ("C'est Novembre") ;

      12 : Ecrire ("C'est Décembre") ;

      Sinon : Ecrire ("Erreur, Tapez un numéro entre 1 et 12") ;

      FinSelon ;

      FIN

    • Exercice N° 11

    • Ecrire un algorithme qui demande un entier de départ, et qui ensuite affiche les dix nombres suivants. Par exemple, si l'utilisateur entre le nombre 17, le programme affichera les nombres de 18 à 27.

      Algorithme dix_suivants

      Variables n,i : Entiers ;

      DEBUT

                  Ecrire ("Entrez un entier : ") ;

                  Lire (n) ;

                  Pour (i ← n + 1 à n + 10) faire

                              Ecrire (i," - ") ;

                  FinPour ;

      FIN

    • Exercice N° 12

    • Ecrire un algorithme qui demande un entier, et qui calcule la somme des entiers jusqu’à ce nombre. Par exemple, si l’on entre 5, le programme doit calculer : 1 + 2 + 3 + 4 + 5 = 15

      Algorithme somme_entiers

      Variables n,i, somme : Entiers ;

      DEBUT

                  Ecrire ("Entrez un entier : ") ;

                  Lire (n) ;

                  somme ←0 ;

                  Pour (i ← 1 à n) faire

                              somme ← somme + i ;

                  FinPour ;

      Ecrire ("La somme de 1 jusqu'à votre entier est : ",somme) ;

      FIN

    • Exercice N° 13

    • Ecrire un algorithme qui calcule le Plus grand commun diviseur "PGCD" de deux entiers à l'aide de l'algorithme d'Euclide (exemple A = 12 et B = 8, Alors PGCD = 4)

      Algorithme PGCD

      Variables A, B, Reste, PGCD : Entiers ;

      DEBUT

                  Ecrire ("Entrez deux entiers : ") ;

                  Lire (A,B) ;

                  Répéter

                              Reste ← A mod B ;

                              A ← B ;

                              B ← Reste ;

                  Jusqu'à (Reste = 0) ;

                  PGCD = A ;

      Ecrire ("Le PGCD de : ",A," et ",B," est : ",PGCD) ;

      FIN

      Ou bien :

      Reste ← A mod B ;

      Tant que (Reste <> 0) faire

      A ← B ;

      B ← Reste ;

      Reste ← A mod B ;

      FinTantque ;

      PGCD = A ;

    • Exercice N° 14

    • Ecrire un algorithme qui lit 5 notes, les insère dans un tableau, les affiche par la suite, et enfin il affiche leur moyenne.

      Algorithme Lire_afficher_tableau

      Tableau Note[5] : Entier;

      Variable somme, moy, i : Entier;

      DEBUT

      Ecrire ("Donner 5 notes");

      Pour (i ← 0 à 4) faire

      Lire(Note[i]);

      FinPour ;

      Pour (i ← 0 à 4) faire

      Ecrire (Note[i]," - ");

      FinPour ;

      Somme ← 0;

      Pour (i ← 0 à 4) faire

      Somme ← somme + Note[i];

      FinPour ;

      moy = somme / 5;

      Ecrire ("La moyenne est : ", moy);

      FIN

    • Exercice N° 15

    • Ecrire un algorithme qui trie les valeurs d’un tableau de 10 cases selon le tri par sélection

      Algorithme Tri_sélection

      Variable i,j,aux : entier;

      Variable dim ← 10 : entier;

      Tableau tab[dim] : entier;

      DEBUT

      Pour (i ← 0 à dim-2) Faire

      Pour (j ← i+1 à dim-1) Faire

      Si (tab[j] < tab[i])  Alors

      aux ←  tab[j] ;

      tab[j]  ←  tab[i] ;

      tab[i]  ←  aux ;

      Finsi ;

      FinPour ;

      FinPour ;

      FIN

    • Exercice N° 16

    • Ecrire un algorithme qui trie les valeurs d’un tableau de 10 cases selon le tri bulle

      Algorithme Tri_bulle

      Variable dim ← 10 : entier;

      Variable i,permute,aux : entier;

      Tableau tab[dim] : entier;

      DEBUT

      permute ← 1 ;

      TantQue (permute = 1) faire

      permute ← 0 ;

      Pour (i ← 0 à dim-2) faire

      Si (tab[i] > tab[i+1]) alors

      aux ← tab[i] ;

      tab[i] ← tab[i+1] ;

      tab[i+1] ← aux ;

      permute ← 1 ;

      Finsi ;

      FinPour ;

      FinTantque ;

      FIN


    Chapitre précédent
    Chapitre suivant

     
    InfoNuls 2010-2015 - Powered by Manhali